Injectors cut off


Site Supporter
r reg sr won't start. Engine check light flashing.
thought it would be ignition switch like 10 years ago. Doesn't seem to be.
thought it would be key chip gone dead so changed ecu and all nats stuff with the spare ones ive had lying around. still no luck
changed relays fuses with spares. still no go
new battery as old one was giving up. no change

engine check light flashing. injectors are cut off supplying no fuel.
when i changed the ecu with matching key and immobiliser unit engine check light stopped flashing car started but few seconds later injectors cut of again
cleaned engine bay earthing points . still injectors cut off and engine check light flashings. gave up for the day. any ideas welcome.



Site Supporter
have you checked the injectors for 12v feed zed ?

when i swap over the ecu with matching passenger pillar nats device plus matching key car starts for 5 odd seconds then cuts out again. haven't checked injector voltages yet but sure they are cuttin off stopping fuel delivery
Hi, you can fit an earlier non-nats ecu, swap around a few wires and you're done. Most of the people in this forum refer to Ed from fusion motorsports for a solution, but Ed his info is no longer online, his micra links on his website are dead and he doesn't respond to emails. I've spent some time trying to fix this exact same issue, and have fixed it 100%.

This fix is for the micra with the key with the red chip in it, and the non-coilpack engine with the single distributor.

Get an early ecu (the oblong one, not a square one) that fits your engine (either cg10 or cg13).

On the engine loom (so on the plug to the ecu) switch over these wires:
switch pin 106 to pin 104
switch pin 12 to pin 36
switch pin 31 to pin 22
switch pin 40 to pin 30

After this your car will not have an immobiliser anymore but you can still use your old keys.

you can send some thanks to => I've spent considerable time on this, but would like to share the knowledge (unlike some!)

k11 nats to no-nats conversion.png

If you have an australian car, you can just plug in a non-immobilised ecu and it will just work!