Consult info

kristian

One Way Mule
alreet guys..

Ive gone and got myself a Consult cable with software.. although, being handy with components, in not very handy with actual programming and the software I have is a little bare bones -> daunting..

Ive had a search and most of it is over my head.. however I have discovered a few things.

1stly

Is the different software interchangeable with different cables.. ?

Im looking for, as easy to use, as possible interface for these initial leaps into the world of protocols, clocks, datalogging, graphs etc etc..

2ndly

Ive got the 'com port' type connector.. is it possible to simply stick on a USB adapter, and connect it via this medium?

Much thanks for any help guys.. also anything ( software, pics ) anyone could send me would be really cool..
 

James

Chairman
1st) yes, do a search for "nissan consult software" on google - CalumSult and ECUTalk are two free good ones I've used
Also try ScanTech: http://techdiag.co.uk/obdscantech/web/pg002.html - it used to cost but is now free
2nd) yes, so long as the USB -> Serial convertor gives it a COM port (which they all do IIRC), you should be fine :)
 

ollie240585

Ex. Club Member
I use Nissan Data Scan, it is software which needs to be purchased but i prefer it to Calumsult and ECUTalk

You can record your logs and then view them back in either a graphical form, or in a dial form. It is useful to see what your car is doing. I have attached 2 pictures of the same data log, It was a log of me idling the car for about 5-10 seconds so doesn't actually show anything, but you get the idea.

It also lets you do basic things with the ECU, can turn any cylinder on or off with the engine running, turn the furl pump on or off, adjust the AAC valve, and a few other bits, just for diagnostic testing.

You can also check ECU error codes and clear them.
 

Attachments

  • nds1.jpg
    nds1.jpg
    195.1 KB · Views: 208
  • nds2.jpg
    nds2.jpg
    149.8 KB · Views: 175
OP
OP
K

kristian

One Way Mule
thanks guys..

Im gonna have a mess around with the software today then ill try James' advice..

how much is the NDC ollie?
 
OP
OP
K

kristian

One Way Mule
ok, got the usb adapter but cant seem to get a connection still?

Ive gone into the properties of the adapter in 'system' devices and set it to com port 1..

The Cunsult software now recognizes that com port 1 is valid but wont 'initialize'

its the same response if nothing is pluged into the computer..

Does this initial, 'initialize' stage mean its connecting to the cunsult adapter?.. of the car itself.

I cant seem to figure where the break in the chain is...

The ignition on the car is on and im using the scantech softwre..

any help guys?
 

richj

Banned
You might need to manually set a baud rate. Have you got a link to the tech specs of your consult interface and the usb adapter?
 

superls

K10 Tuner
this may not apply but i found 2 things out when connecting similar things to my dads beemer.

1. the usb serial adapters do not work, specified that in the manual. tried almost half a dozen different ones, no joy, come to think of it my pic programmer doenst work with the converters either.

2. i was spaeking to a mate of a mate (hes a computer geek) and after he told me that it wouldnt work (after days of trying) he mentioned something about one of his serial things that he had used through a converter would only work on his laptop (assuming your using a laptop???) after hed rebooted it with it connected it wouldn't work if the laptop had been on standby or in hibernation it had to be robooted.

hope it helps
 
OP
OP
K

kristian

One Way Mule
Still having no bloody luck!

SuperLS I tried that.. no luck lol..
\
Thanks for the link James.. no idea how to implement that though?.. ive downloaded what im assuming is the right one.. XP one.. its got no '.exe' executeable installer or anything..

Sorry for the noob questions guys.. just getting to grips with it..

Am i best dragging the whole desktop into the boot of the car and use the Com port in that?

..or is there a way of checking for sure the USB -> Com adapter is working.. and its down to a faulty Cunsult board..?

thanks..

-------------------------------------------------

Infact, could anybody whos using the same or similar software as me tell me if they get the same error message:

If its connected to the car and the car is switched off,

If the Usb Adapter is connected but the consult 'board' isnt connected...

I need to be sure this 'failed to initialise' error is not the final cable running to the Actual Consult Socket next to the fusebox IN the car...

This came with the Consult board, so im assuming its correct..

Thanks for any help guys..
 
OP
OP
K

kristian

One Way Mule
Back to square mother ####ing one!!...

ok guys.. ive bought another NEW consult adapter thing.. this one has an LED on it and has a neat white case and plugs into the DDL connector..

Ive tried to old datascan software and CONZULT software.. and both of them fail..

Datascan - failed to initialise
Conzult - Win error - com2 ( this is the com my prolific serial adapter is set to.. )

Wheres the problem..?

Both show the same error if the thing is plugged in or not.. wtf

the led always is off, if this makes any difference..?

.. im persuaming its the usb-com adapter lead.. but i had same problem when I connected straight into motherboard when i lumbered my desktop pc outside too..

any advice greatly apriciated
 
i know this is an old thread, but if u still havent fixed it, and your car is indeed "K11 SR20DE converted" then id put my money on your consult port not being wired up to the ecu (ie wasnt properly done in the conversion)
 

James

Chairman
I believe he solved it when he borrowed my ECUTalk LCD display! ;)

I think it was the cables he was using (I still have one of them with me, plugging into mine doesn't even light up the LED on it!)
 
cool. yeah those chinese consult interfaces are hand assembled and theres often errors in assembly, wires to the wrong place on the connector or similar, shame the ebay sellers and/or manufacturers dont bother to test them
 
Top