K11 Rough Idle with Engine Light Flashing


Club Member (Trial)
Hi Guys,

Have trawled through various sites on the net trying to get some information about this but cannot.

The Car:
Nissan Micra K11 P-reg Vibe 1.0l Manual, non air-con, pretty basic model. 106k miles

The 'Incident'
Got caught in the classic engine flooding scenario, started car, moved it down the road slightly to let car out of drive, switched off. Couple hours later, needed to go down the shops but it wouldn't start, engine flooded, can smell fuel in bonnet. Tried to start it a couple of times but no joy and gave up and started doing some research on the problem.

Next day i had it all sorted in my head, started car with foot to floor on acc pedal, which signals the ECU to not inject any more fuel, and after 3x 30sec cranks it started but was very very rough, revved it a little to just make sure it wasn't anything that needed clearing out. Switched off and investigated, only to find that my dad had also taken the job on of fixing the car and had disconnected cylinder 4 (nearest distributor) spark lead to test for a spark and had forgotten to reconnect. So reconnected cylinder 4 lead and engine starts first time, however now i have a check engine (orange) light flashing on the dash and the idling appears to be too low, when starting it revs to about 1000, then drops down to 400 (battery charge light comes on for a sec) then revs stabilise at 500. Having driven the car for a while, i know that it shouldn't do this, before the flooding the car had started/run fine from cold. (revs are estimated as i don't have a counter, but the principal is there)

So now i have performed the ECU tests with the DDL connector in the fuse box, orange light flashes slow 14 times, then quick 3 times, giving me a fault code of 143. Which means nothing to me :doh:. Also i note that the IGN pin on the DDL connector is not outputting a voltage and i had to tap the +12V from the radio connector and pipe that into the CHECK pin. Also note that the NATS light on the centre console flashes even when engine running (this is a recent thing too).

I have read a lot about the Throttle bodies going over time but this is a simple case of: car was working fine, engine flooded, cyl4 disconnected, cyl4 reconnected, engine not running fine which leads me to believe that it isn't a 'gradual' failure of anything.

When warm the idling prob is less noticable, when cold sometimes the engine rpm dips so much that it will stall at junctions etc. When under load the engine has no problems, and has the same power/performance.

So now i have an engine with an idling problem and an orange light flashing in the dash all the time, with a fault code of 143. Can anyone shed some insight onto this?

Some Ideas of my own: (Stop me if i'm getting ahead of myself here)
Assuming ECU was still pumping fuel into cyl 4 when lead was disconnected and engine revved and cyl 4 spark plug may be damaged (however why would the ECU be flashing over a spark plug)

ECU sensors are outa whack, have multimetered a few including water temp, AAC value and performed ECU tests on oxygen sensor and they appear to be within spec.

Anyone had/having similar problems, and hopefully solutions?

PS: I've tried to be as detailed as i can about the run upto the problem and about the problem itself.


I have had similar problems, however mine cuts out entirely, it seems to be totally random as well, either when it's just idle or if I'm crawling through traffic, blasting down the motorway. It feels like all the power goes from the engine and the revs just drop away. I've checked plugs, ht leads, dizzy cap and fuel line. When i went to check the main fuel line it was totally dry...weird. I'm gonna have to take the fuel pump out and hopfully it's just a simple case of it being full of crud, in the manual it says i have to change the fuel tank rubber sealing when i open the fuel tank access hatch, if anyone knows where I can get that part that'd be great cos I can't find it anywhere on the net!



RIP Colin McRae 1968-2007
Click Me

This might help you a bit further mate! As it says bridging the two pins after the sequence should clear the ecu's fault codes incase it is just a fault that needs reset then you can fiddle about to see wats causing the fault to re-occur.

Also found this on a site:
143 Immobiliser function in ECU (no/incorrect signal)

Fault Codes

May not be related but sounds about right if the engine check light is on as this could be part of the immobiliser!

JJ 1.0l

Ex. Club Member
i had a similarish problem about a month ago.

basically, i park my car on the drive which is sloped and i faced it out so the bonnet was "uphill" and that week it rained ALOT. this caused my car not to start and i could smell alot of petrol so i stopped turning it over.

found out that the water had got to the spark plugs and needed some new ones.

so it maybe your sparks, i am not an expert but might be worth a try.


Club Member (Trial)

Hi Guys,

Will be checking the plugs soon, havent had time to go to halfords to get the extra long plug tool :doh:. Seen some interesting posts about the AAC value and carbon buildup which might be fruitful.

also i have tried shorting the DDS plug pins and the check engine light will go out until the ignition is switched off/on again, in which case we go back to error code 143 again..

Hmm immobiliser sounds possible, but surely the car wouldn't start at all, let alone run for any length of time. I did see the 143 = immobiliser fault but that was on an almera or similar ecu so i didn't take it for gospel.
I have the exact same problem dkaygoo

I flooded my engine knowingly by moving my car about 2m! Did the fuel pump fuse trick to get it starting straight away but then I noticed my revs were a bit erratic at times. However im pretty sure it started before flooding my engine. At the dartford crossing i slowed to a stop paid my money and no power... it had stalled even with the clutch fully depressed. Didn't think much of it at the time, thought i had somehow done it.

It was really bad the other night stalling whilst still moving at a roundabout at low speed and over speed bumps the engine light would flicker saying it had stalled but then recover until the next bump.

I cleaned the AAC valve but still getting dips in revs. Pretty sure the prob is around the throttle body as all problems stem from there in a K11. Gna take it out and see if theres any blockages in that, then maybe try some fuel cleaner apparently that has worked for other makes of cars.

Let me know if you solve your prob.
Fixed my car today.

It was the Throttle body. Took it out, cleaned the carbon sludge that gets in there and re-soldered some joints on the circuit.

Job done.


Club Member (Trial)
Hi Guys,

:k11green: (ooo vibe green)

Only just managed to get in the bonnet, things have been busy over the last few weeks, ok checked AAC valve, no problem there, opens fine and returns under the magnetic force. Only just managed to get the air filter off today and checked on the throttle potentiometer, can i just check some values with you guys, i have a Hayes book which is telling me some resistances but something isn't right here...

OK imagine you are standing at the front of the car, the throttle potentiometer connector is pointing up to the sky... Now imagine pin 1 is the closest to you. The values i'm getting are the following;

Between pin 2 and 3
Fully closed: 4k ohms
Fully open: 1k ohms

Between pin 1 and 2
Fully closed: 0.7k ohms
Fully open: 3.6k ohms.

The problem is my haynes book is telling me to measure between the middle "and back" pin, now i'm assuming back means pin 3, and i should get readings of;
Fully closed: 0.5k ohms approx
Fully open: 4.3k ohms approx

Compare this to my readings to pin 2 and 3 you notice there is a problem. Now either i've assumed wrong about "the rear pin" from the haynes manual or my throttle potentiometer is backwards.

Compare that with the error code i'm getting of 143, to the haynes book saying 43 is a throttle potentiometer circuit fault and i'm on a bit of a wild goose chase. :doh:

My question, to all you lovely people out there with *loads* of time on your hands (hehe), has anyone got any *actual* values from their potentiometer for me to compare against my values for pin 2 and 3.

Oh an just as a side note, i've got corrosion in the fusebox nearest the front bumper and it's taken out the offside front light, o_O how easy is it replacing either that fuse box or just the contacts to fit new ones?


Ex. Club Member
Club Member
try getting it towed from a friend and at 30mph and then drop it in 4th :) it worked for my 1 ltr when i moved my car 5 yards out of drive for a few hours. - bump starting done the trick:)
on the left side of the throttle body, there is a small metal square with black silicon. cut the silicon out with a sharp knife and pull the square off to reveal a circuit. Now a common trick is to resolder the six joints (3 opposite another 3 that go away from the circuit board). Theres a few websites on the web that have pics.

Just try this and see if that solves the problem first, as it is very common theses joints get dry (even though they may not look it) and leads to idling/generally rubbish performance.


Club Member (Trial)
Hi Guys, good news.. i have sorted the problem..:laugh:

I found some wiring diagrams in the haynes manual and noticed that the IGN pin in the diag connector, power to the AAC value and the heater on the exhaust sensor were all on the same line, also note in an earlier post that the IGN pin never worked.. so after a lot of continuity testing on the pink wire i found that the spade terminals of the fuse were not coming into contact with the fuse box connector.

After fixing that the engine is starting perfectly, however with all the cleaning of the AAC valve and such i have a slightly high-idle, even when hot, so i'm going to have to deal with that, without a rev-counter i'll have to wait on that... anyone know the colour of the wire on the dizzy that outputs the switching negative so i can get a frequency (Hz) reading from the multimeter from?

Thanks for your help guys, i dread to think how much a nissan garage would have charged for all the diag, and then they would have prob replaced all the sensors (and prob throttle body) before actually finding the real prob.

So, from my experience, error code 143 means check the fuses and housings, if they are ok, check that the pink wire on the AAC connector, pink wire on exhaust sensor, and pink wire on the diag connector (IGN pin, bottom left) all output +12V when ignition is switched on.

Hope this helps, i've seen some other people struggling with a 143 fault code