Flashing Service Light on Dash

Hi I have a 54 plate Micra and the service light on my dash is flashing when I first put the key in, it goes off after the engine has been started.
I have tried all the things to turn it off and have taken it to a garage this morning for them to have a look.
They said it could be a faulty wire causing the flashing. Has anyone else had this? The car is not due a service.
Thanks
 
OP
OP
MicraJan
Try a reset.


:cool:
Hi

I had already tried a reset following instructions I had found in this forum before I took it to the garage.
Nothing seems to stop the service light flashing when you first put the key in ignition.

Thanks
 
OP
OP
MicraJan
Also it is the MK3 K12 model so the dash doesn’t look like the one above. It doesn’t have the computer above the radio either
 
Maybe you should take a photo of what the cluster looks like or the screen.
Mine has the one were the radio is and I have not reset that before.
Would the procedure be the same as in the video on the 05 prefacelift?
Sent from my ASUS_T00P using Micra Sports Club mobile app
 
Last edited:
OP
OP
MicraJan
Hi thank you both for the tips. Here is a picture of my dash and the part where the radio is. I tried the same method as the newer shape model in the first video link but that didn’t work.
64911

64912
 
So far I have seen a few k12s without the computer screen and the first type of cluster.
On mine if I press that button it resets my miles driven I think.
Not sure what happens if its held down tho.
I'm pretty sure the buttons have same function as the cluster is identical.
Check your manual to see if they do anything more. Than resetting miles driven.


P_20190906_213735.jpeg


Sent from my ASUS_T00P using Micra Sports Club mobile app
 
Top