NATS Wiring - Not trying to bypass it, trying to keep it.

Has anyone got a wiring diagram for NATS on a '98 K11?

I'm transplanting the engine into a different car and I thought it might be a good idea to keep NATS. So I carefully unwrapped all the wiring in an effort to see where the wires to the NATS unit went and thought I had it all straight. Obviously I wasn't careful enough because now I've cut the un-necessary parts of the loom off and wired it all as I thought it should be it won't start and the engine light is flashing which is exactly what it did with the transponder ring away from the key.

Am I right that all I need is the ECU, the box and ring (reader) from the ignition switch and the keys? There isn't another box lurking somewhere that I've missed is there?

Assuming I'm right.......

There's a wire from the reader to the ECU - presumably how the ECU gets the code from the key to decide whether it's the right key or not.
There's a wire from the reader to the stereo - I believe this will stop the Nissan stereo working. The stereo was out when I got the car and there are no other connections on that wire or in the plug so it doesn't need to be connected to let the engine run.
There's an earth connection.
There's a wire to the LED. The other side of the LED went to the fusebox - what does it get from there? I thought it was permanent power but can someone confirm?
There are two other wires that went to the fusebox. I thought one was a permanent supply and the other was a supply on cranking the engine.

Anyone?
 

skymera

Brutal Honesty
Has anyone got a wiring diagram for NATS on a '98 K11?

I'm transplanting the engine into a different car and I thought it might be a good idea to keep NATS. So I carefully unwrapped all the wiring in an effort to see where the wires to the NATS unit went and thought I had it all straight. Obviously I wasn't careful enough because now I've cut the un-necessary parts of the loom off and wired it all as I thought it should be it won't start and the engine light is flashing which is exactly what it did with the transponder ring away from the key.

Am I right that all I need is the ECU, the box and ring (reader) from the ignition switch and the keys? There isn't another box lurking somewhere that I've missed is there?

Assuming I'm right.......

There's a wire from the reader to the ECU - presumably how the ECU gets the code from the key to decide whether it's the right key or not.
There's a wire from the reader to the stereo - I believe this will stop the Nissan stereo working. The stereo was out when I got the car and there are no other connections on that wire or in the plug so it doesn't need to be connected to let the engine run.
There's an earth connection.
There's a wire to the LED. The other side of the LED went to the fusebox - what does it get from there? I thought it was permanent power but can someone confirm?
There are two other wires that went to the fusebox. I thought one was a permanent supply and the other was a supply on cranking the engine.

Anyone?
NATS2 (yours) is built into the ECU and cannot be bypassed like the earlier NATS.

I can probably get an ECU wiring diagram if it'll help
 
OP
OP
I
Thanks Skymera - As I said I'm not trying to bypass it and the info I'm after shouldn't help anyone else to do that as you would still need the keys. I've got that diagram and it's largely correct for my car but you'll notice that it only shows the one wire from the "NATS immu" to the ECU.

Frank - do you know anything about the wiring connections? I haven't seen anything in there but the car's passenger side is hard up against a wall so I can only get in from the drivers side and there's a Cosworth V6 engine sat where the Micra's passenger seat would normally be - the next project.

Iain
 

frank

Club Member
98 was the facelift changeover year eh, and the wiring is different, how many wires has your antenna got ?
 
OP
OP
I
I't just got the six wires mentioned above. I'm sure it's one of the three that went to the fusebox that I've got wrong. I've assumed that they are just getting power from there at some point or other in the starting sequence. Unfortunately I don't have a diagram of the insides of the fusebox so they might well have been connected internally to wires that went somewhere else - I just thought I had it sussed.

Iain
 

frank

Club Member
i think the nats 2 has 4 wires and a nats box, but the later nats 5 has more wires (6 or 7 ?) and no nats box, baguette posted some info iirc
 
OP
OP
I
I've had a dig and Baguete did post a thread where he seemed to be after similar info as he wanted to transfer a later engine with it's NATS ECU and associated bits into an earlier Micra. He didn't seem to get an answer in the thread so I've sent him a PM to see i he ever got the info or if he went an alternative route.

Searching the web I can find exactly the diagram I need - for a K12. Seems odd that the info isn't out there anywhere for a K11. I do have a more comprehensive manual on it's way so I'll see what level of detail it goes into. If I do get it sorted I'll post the info back as I can see it being useful both as a problem solving tool for those with this NATS system in their motors and as it would give an alternative to finding a non-NATS ECU if you could carry a NATS one across complete (at least for the same system as mine has).

Iain
 
OP
OP
I
The plot thickens. I've got it running but the immobiliser LED and MIL are now playing silly buggers - not completely necessary for my application but it suggests something is still not quite right and it would be nice to sort them properly.

As mentioned there are 6 wires on the immu. They are

Green&Black - LED black wire
Pink&Black - To ECU
Black - Earth
White& Black - To Stereo

Now here's where I'm less sure

Yellow&Black - Permanent power
Pink - Permanent power

LED red wire - Permanent power.

Connected like that the engine will run and the MIL behaves itself but the LED never flashes. If you disconnect the pink wire the LED flashes but the engine won't run and the MIL flashes. In connecting and disconnecting that pink wire though I've also had it at the point where the engine will run but the MIL keeps flashing constantly.

This suggests to me that there is maybe a diode missing from the circuits and something is getting a back-feed that it shouldn't.

All suggestions/ideas greatfully received.

Iain
 

frank

Club Member
the factory service manual (pdf) download link might still be active ? (2 or 3 months ago, on here)
 
OP
OP
I
Found it. Page 265 on Electrical-1.pdf.

Easy when you know where to look. I'll have another go at it tomorrow night and see if I can get it all working as it should.

Iain
 
OP
OP
I
Right - had another go last night with the wiring diagram in my grubby mitten and presto! it works. Engine runs fine and all lights behaving themselves.

Thanks for the assistance folks.
 
could you possible send me a wiring diagram for 2007 1.2 micra i have a fault code showing nats sytem fault and ive checked all fuses but not sure where to start thanks
 
Top