Wiring: Ignition, Dipped Beam or Parking lights?

Need some help with 2 wiring bits.

1.
Wiring up the roof lights, and need to connect the switch backlight LEDs to a feed. I don't want to hook it up straight to the igntion or live as it needs to glow only when the normal lights are on. Where's the best place to grab a feed? Not so keen to run a line all the way to the headlamps from the dashboard.

2.
Again, wiring up the switches - where's the best place to grab an ignition feed for the relay? Don't want any of this to get current until the ignition is on so as not to drain the battery. I'm guessing off the back of the radio would work, but not sure what wire I'm looking for. Any ideas?

Thanks!
M
 
Do you have a multimeter? If yes then check voltage on the radio wires with the ignition on. As for your first question if you use a relay on the headlamps you can use that relay to power on the roof lamps
 
Quick explanation
 

Attachments

  • 1433582108937.jpg
    1433582108937.jpg
    32.5 KB · Views: 242
OP
OP
Spinal
Thanks - that wasn't what I was trying to do - but thank you :)

What I'm looking for is a wire in the center console that is live when the lights are live. Think of the things that "turn on" when you turn on the headlights (all the backlit switches). Still looking, not sure if the rear heated window switch is meant to have a backglow when the lights are on.

Now also looking for an RPM line to fit a tachometer... all I find are pre-facelift diagrams, no facelift ones... and there's so many frigging cables off the back of the ECU.
 
The tacho wire is a blue one at the back of the clocks I think there are two so just probe and try. Why don't you use one of the t10 sockets behind the heater controls. They turn on with the lights and are easily accessed taking the centre console off you could tap into there
 
OP
OP
Spinal
Splendid, thank you. For some stupid reason, I spent all morning probing the wires and didn't think of just tapping into the bulb sockets. I'm an idiot. It's official.

As for the tacho - I was looking down under by the ECU, have the dash out (changing all the bulbs for leds) so will have a probe there now.
 
OP
OP
Spinal
I have tried both these:
blue/black
blue/yellow (or green, hard to tell)

Will check again, as I'm probably being color blind.
 
OP
OP
Spinal
Got it! It was the blue/black line - what I had missed was that the +ive line I was using for power had a blown fuse. Doh!
 
OP
OP
Spinal
Next challenge. It would appear that most of my center console bulbs are blown (hence the reason I couldn't figure out where to connect :p). The switches (e.g. hazard light) have a TINY bulb inside, and I do mean tiny. Much smaller than a T5. Any idea what this bulb is? It's barely larger than a grain or two or rice.
 
No idea. Its not a 3mm led is it?? Even if the bulbs are blown the sockets should still have current. If not its a fuse gone. I still think it would be easier tu use the t10 for what you want easier to wire and access
 
Top