tweeter output issues

N1554N

Site Supporter
i just got hold of some a-pillars with tweeters (for a K11 micra). hooked them up (as the connectors where already in place behind the old a-pillar covers) but the sound coming through them is ultra quiet.
i'm running standard speakers off a sony xplod head unit.
does anyone know how these tweeters are wired in? i.e. are they running straight off the head unit with no crossover?
seems they just need some sort of amplification?
ideally i'd like to get some components, and still use the original tweeters - but will need to know how to hook them up to the crossover so will need to know where the wire runs into the loom behind the head unit/tracing it behind the dash.
not looking for a high spec system, want to keep all the fittings OEM but upgrade the speakers in the door. i have some Fli integrators, but not sure i can use these in conjunction with the tweeters as these are full range/coaxial speakers.

hope some one out there can help....
 

Shaun

***StaGGeRed***
perhaps the original head unit had an amp built in for them. perhaps now you need crossovers.
 

Hugh

Moderator
Moderator
Check the cross overs for the tweeters as it may be set high to something like -10DB
 
OP
OP
N

N1554N

Site Supporter
Check the cross overs for the tweeters as it may be set high to something like -10DB
if only i knew where they were...they're standard tweeters, i've tried looking for wiring diagrams or images to see where the wires and crossovers may be, but no luck.
i may have to remove the dash to see.
I would like to know if its possible to remove the dash without having to take off the steering wheel - all i need is to see if there are any crossovers/where the wires run....
if there is a crossover, surely that means i cant run a decent sound through components if i just use the wire from the door speakers...??
 
Top