No Indicators??

Right lads....
On me way to work, my turn signals worked fine.

But got out of work, and nothing word. Left, right, hazard signals don't work!!
Got home and checked the fuses for the turn signals and for the hazards, and they're all fine. Even all the bulbs are ok.

So anyone else got an idea of what it could be??
It's a Nissan Micra '01 that I'm having problems with.

Also, the battery might be dying as I've had to get a jump start a few times during the week, would that affect it??
 

NeX

You're after my robot bee
Club Member
Right lads....
On me way to work, my turn signals worked fine.

But got out of work, and nothing word. Left, right, hazard signals don't work!!
Got home and checked the fuses for the turn signals and for the hazards, and they're all fine. Even all the bulbs are ok.

So anyone else got an idea of what it could be??
It's a Nissan Micra '01 that I'm having problems with.

Also, the battery might be dying as I've had to get a jump start a few times during the week, would that affect it??
i had the same thing the other day, my car just stopped indicating. and same again no problems with any bulbs or fuses. in my case it was the flasher relay (up behind the dash on the drivers side) you should be able to get to it without removing anything but its a bit of a squeeze. my flasher realy seemed to have dry solder joints so i took the relay apart and heated up all the solder with a soldering iron and put new solder on. its been fine ever since.

but there is one more thing it could be. if the hazzard lights switch is not plugged in (it obviously doesn't work) but your indicators don't work either. i found that out when trying to drive the car with no dash. if you have done anything to it recently and that plug has popped out, it could be the problem.

good luck :)
 
Top