• Please only use these forums for blogs, they are not a discussion forum

Micra K12 - - car running rough and Kangarooing - no Code (P0132) fixed

Hi

thought I would share this in case its any help if you are in the same situation;

Daughters 2006 K12 - started running rough and kangarooing - felt like the power was cutting out then it would suddenly lurch forward.
Could not get a code from the reader - none showed. Changed the plugs, air filter and cleaned the throttle valve - still no code. Took the rear lights out to check for bad earth, cleaned up, still running dog rough but then showed a code P0132 - pre cat Lambda sensor. Bought two from Eurocarparts £46.00 each. (and a sensor socket as it looked a pain to extract without).

The front one was a problem due to lack of room so tackled the rear one first. Even though this was not showing as an error code some googling told me that sometimes the rear fails and the fault shows on the front one.

Replaced the rear one - came out OK - right hassle getting the new one to thread correctly. Eventually went in only to find the plug was different :mad:. ( The plug on the front sensor is a small one that matched the Eurocarparts universal plug the rear one was bigger! - Took it out again, cut the wires, spliced the old plug on the new sensor, put it back in. (a lot easier this time as the threads were clean.

Started in up - runs like a dream. (back to Eurocarparts for a refund on the other Lamba - make sure you don't open the packaging)

So my advise - if you get P0132 think about doing the rear sensor first!
 
Top