K11 won't start


I posted a similar thread just now on Cisco's, but doing it here too just in-case anyone can help (I'm in a pickle!).....

I moved my K11 a short distance yesterday, and now it won't start. I thought that I had committed the usual sin of not letting it warm up enough, so I did the old take out the fuel pump fuse, crank her over till she fires .... but she didn't fire. I actually flattened the battery I tried so hard. Fuse in, fuse out, no starting. Even tried with a jump off another car. Nothing - cranks away, but no sign of life.

Anyway, I removed & recharged the battery over night. Today its the same story. I just noticed that the orange engine management light is not coming on at all when the key is put in, and it should as I recall. I believe this is the real culprit, but how to proceed? I've checked all fuses under the dash and under the hood (that I could find), but all are fine. I even tried the bent piece of wire trick on the ECU connector to see if that could coax any life out of the engine light - nothing. Hoping its just a fuse and not a dead ECU.... Could it be the key?

As ever, all advice very gratefully received.


My K11 developed a very intermittent start problem. Would crank/turnover but not fire/start. Otherwise ran fine in between bouts of non start (no stall issues, no uneven acceleration etc). Felt like a fuel issue to me and the previous owner - not very motor savvy mind - thought it was fuel filter issue.

When the car would not start, radio/dash lights would turn on an go out when key turned, sometimes radio would come on and sometimes not - when the no start problem was happening.

Everything I read on the net seemed to suggest that whilst a ignition switch/barrel might just be the issue, it wasn't necessarily a high contender because the engine cranked and there was no actual firing and a stall at any time.

Jiggling the wires that went into the ignition switch / ignition switch connector turned dash lights on and off with the key in the ignition - so obviously there was a loose connection - but that for a novice like me was not neccessarily the whole problem.

My problem turned out to be ignition barrel/ignition switch.

Swapped those out and the engine started first time. Bought on ebay.

My system was nats2 - transponder key with chip in the key (red cap).