K11 Wiper Relay..

Hi folks,

The intermittent speed on my mum's 1993 K11 1.0LX has stopped working.

I suspected it's the wiper relay (the little black box next to the wiper motor). I visited to seperate breakers yesterday and tried relays from broken Micras.

The first one caused the intermittent speed to act really weird. Basically the wipers would start, move about 6 inches, then stop. Then a few seconds later, move another 6 inches and stop...and this goes on and on.

So i gave that relay back.

Visited the second breakers and that relay did exactly the same as the current one already in the car. It basically just causes the wipers to work continuously as if they are on constant speed 1 (position 2 on the stalk).

Soooo... is it possible that both the relays i tried were just faulty as this is probably a common problem on K11's. Or is there probably something else wrong with the wipers?

Is it possible to repair the relay at all? A bit like renewing the dry joints on the K11 MAF - which i did a couple of years back.

All help appreciated.



You're after my robot bee
Club Member
i have a k11 1.3 Lx, it is kinda old, but i wanted the nice new indicator stalks in there. the wiring didn't quite match up and i had alot of problems getting the intimitent part of the wipers working. eventually i sorted it, but it wasn't easy.

so anyway the relay box could be year specific, so try getting one from the exact same year as yours. also the indicator stalk could be damaged, try getting a new one of them, again it is very year specific, i had what i thought was two identical stalks but on closer inspection one had an extra pin on the plug and it made all the difference.

good luck


Club Member

i agree, maybe the dwell electronics are in the stalk and the intermittent/non intermittent relays are the same ?
Hi guys,

Many thanks for the replies.

That's very interesting actually, maybe you're onto something there.

I did try removing the relay and trying the wipers to see what happens. On position 1 (Intermittent) they just don't work at all. But on 2 and 3 they work as they should.

So that tells me that the relay does actually control the intermittent speed circuitry.

I think perhaps the relays are actually year specific so i will need to find one from another Micra 1993 model to see!!



Ex. Club Member
Did you manage to fix this?? My cars doing the same now. Where can I get a int. wiper relay from?? Mine keeps blowing the window wash fuse too.... Its been acting like this since the car woke up one morning and said "Bonjour!"
Hi mate, sorry for the late reply I don't actually frequent this forum much. I had another go at this for my mum today as I never got hold of a working relay..

I tried two different stalks at a breakers, but same problem. I therefore think it is definitely the relay.

I read somewhere that the K10? (older shape than K11) share the same relay as the early K11's - but I'm not sure how true that is..

If anyone has a working relay from a 1993 or possibly 1994 car please PM me - thank you.


Ex. Club Member
I'm having a similar problem, except mine goes at the slower speed at both positions 1 and 2 and the faster speed at position 3, and the wipers don't park, you have to time it and switch the wipers off to co-incide with the blades reaching the parking position. Using the wash-wipe is also hit-and-miss, usually takes several goes before the wipers stop at the bottom. The rear wipe works perfectly. I've searched the forums for this and this is the closest related topic. I will investigate and if I fix it I'll post here. 1993 K11 LX by the way.



Ex. Club Member
Update: I took the relay apart and found several dry-joints on the connector pins, so I resoldered these and unfortunately it made no difference. There is rather a lot of gunk in the motor connector, which I presume was put there to stop the damp getting in and corroding the terminals, so my next job is to squirt it with switch cleaner, re-spring the spade connectors to improve the contact and give it a coat of petroleum jelly to keep the wet out. If this doesn't work I'll test all the components on the relay board.