K11 Idle control valve - How to clean

Hi All

I want to clean out my Idle control valve (as in the photo), as getting bad idle from cold, (ok when warmed up).

Is it a case of undoing the screws and rinsing with Brake cleaner and cleaning with a toothbrush?

Anything, I have to watch for, IE gasket etc, do I have re-lube the O ring, if so what with?

Thanks
 

Attachments

  • ICV.jpg
    ICV.jpg
    7.5 KB · Views: 50

pollyp

Club Member
yup unscrew,
take out,
keep the o-ring safe (if damaged or gone old hard brittle then replace it),
flush any carbon out the valve with brake cleaner & brush & swivel the inside valve 90deg with ur finger to loosen any dirt & ensure the valves ball bearing shaft ain't sticky,
refit the o-ring onto the IACV, put a dab of oil around the ring with ur finger,
carefuly reinsert back onto the TB, gently twist & push down, it should slide in effortlessly. if it's squishy, recheck if the o-ring is sitting correctly.
secure & plug it in.
 
OP
OP
nesty
yup unscrew,
take out,
keep the o-ring safe (if damaged or gone old hard brittle then replace it),
flush any carbon out the valve with brake cleaner & brush & swivel the inside valve 90deg with ur finger to loosen any dirt & ensure the valves ball bearing shaft ain't sticky,
refit the o-ring onto the IACV, put a dab of oil around the ring with ur finger,
carefuly reinsert back onto the TB, gently twist & push down, it should slide in effortlessly. if it's squishy, recheck if the o-ring is sitting correctly.
secure & plug it in.
Just to say many thanks for the detailed instructions (especially about the twist and pull), followed them, all good, it was the issue, runs smoothly from cold now, cheers!
 
OP
OP
nesty
Apologies, to re-hash this thread again, running like a dream this week, then today cut out randomly twice at lights (though engine was warm), on the ICV is there anything else, which could go wrong? I re-soldered the throttle body about 6 months ago.
I saw this online, wondering if new replacement might help?
 
Cutting out only happened to me when the MAF was dead when I first got the car in 2017.

Do you have a consult device + Datascan?

As for a new ICV I think that their is a setup procedure for them, however I can never get the option in Datascan to enable for myself.
 
Top