K11 1996 OVER HEATING ISSUE

Ok so hey ladies and gents

Looking for some help/guidance

Acquired a jdm 1996 k11 march
She’s a cg13

When purchased after a few miles of driving it begins to increase in temp

Upon getting her home to garage I investigated possible issues and came to discover there was no thermostat fitted to the car atall so I was like ok this is the culprit

I purchased and fitted new thermostat and gasket( and yes fitted correctly)

This did not resolve the over heating issue

Also I’d like to mention it does over head when just turned on a left running for 10-15 minutes

I strongly do not believe it to be a head gasket,as Thier is no gunk/sludge on oil cap and no smoke from exhaust

What could possibly be the cause??

Failed water pump ?
Air lock in the cooling system?

It’s a surprisingly clean dry engine no oil or water leaks

Thanks in advance for any help or tips
 

Chie

Club Member
I would say airlock possibly if there's nothing obvious and you've changed thermostat. I cant remember if they self bleed
Silly question but does the fan cut in?
 
OP
OP
TORK10
Ok guys
Water pump works

I bleed the system to and removed what I believe to be all air or very close to it

Car runs fine now and does not overheat, one thing I did notice is the rad fan stays on for quite some time when it does come on🤔🤷🏻‍♂️

However the car does not go beyond half way temp so it’s not over heating so I’m happy enuff with that,

When I bought the car I can’t get any air from vents ,no cold or hot air, would that be blower motor failed? Or can this be related 🤷🏻‍♂️

Thanks guys
 
OP
OP
TORK10
Ok guys
Water pump works

I bleed the system to and removed what I believe to be all air or very close to it

Car runs fine now and does not overheat, one thing I did notice is the rad fan stays on for quite some time when it does come on🤔🤷🏻‍♂️

However the car does not go beyond half way temp so it’s not over heating so I’m happy enuff with that,

When I bought the car I can’t get any air from vents ,no cold or hot air, would that be blower motor failed? Or can this be related 🤷🏻‍♂️

Thanks guys
All fuses fine by the way
 

Chie

Club Member
Possibly resister pack for blower if the fans not coming on at all. Usually they lose certain speeds and you end up with full speed and nothing on the other settings, it could be its failed all together but I think they are 20 quid on ebay if it is that
 
OP
OP
TORK10
Possibly resister pack for blower if the fans not coming on at all. Usually they lose certain speeds and you end up with full speed and nothing on the other settings, it could be its failed all together but I think they are 20 quid on ebay if it is that
Thanks I’ve dealth with that resister crap before quite annoying

Do you know if a facelift k11 resister is the same 🤔

Thanks for help
 
OP
OP
TORK10
On further inspection the blower motor is seized and not rotating

Also facelift heater blower resister is different to that of the preface

So I think I need new resistor and blower motor also
 
Top