idle control valve

so,i know there 3 screws, the right one is to control the idle,
what about the left and the middle ? havent touched them yet
 

Baz

Ex. Club Member
Better off not touching them, the middle is for Idle up solenoid when you turn on lights the engine idies up 50 -100rpm to compensate the load the left is for idle mixture but I found other sources saying its for a/c idles speed
 
i cleaned out idle control valve while i was doing the resolder which i marked and removed the potentiometer thingy the problem i have is when cold the car must rev about 2000 rpm but once fully warmed up ok coming to a stop the revs go slightly high then drop to normal again after about 2-3 seconds why is this i was beginning to think why i touched the engine i just thought i would nip the faults on the tb before they start
 

Baz

Ex. Club Member
i cleaned out idle control valve while i was doing the resolder which i marked and removed the potentiometer thingy the problem i have is when cold the car must rev about 2000 rpm but once fully warmed up ok coming to a stop the revs go slightly high then drop to normal again after about 2-3 seconds why is this i was beginning to think why i touched the engine i just thought i would nip the faults on the tb before they start

Have you set the voltage at idle on the tps after removing it?
 
I've cleaned out my icv and put it back on now it idles at 2000 all the time and comes back down to 900 with lights fan heater and ac switched on any thoughts be very helpful thanks guys
 

Baz

Ex. Club Member
You need to use the screw on the right hand side turn it clockwise with all lights etc off until it idles about 950-1000rpm. Then use the middle screw to set the idle speed with lights etc on should be about 1000rpm. If you cant get it to idle any lower the unit is broken
 
Hi guys,
I know this is an old thread, but i've been having troubles with my K12 for ages now.

So when it starts it's up at 1500 revs, then over the space of about 5 minutes it very slowly decreases down to about 900/1000 revs. As it's going down the needle slightly twitches up and down and you can hear the engine idle change as it does this. Is this normal? The revs also jump up when I put my foot down on the clutch and go into neutral when in low gears.

Could this be the idle control valve? Or any other ideas? I have contemplated getting the throttle body replaced with a reconditioned one too. I literally don't know what to do, two garages don't know what's wrong with it now and it's costing me money with no answers!

Any help would be really appreciated!
Thanks, Lucy
 
Top