I will just leave you all with this...

imp124

Buy & Sell Member
Club Member
[video=youtube;USsJS-BnGRY]http://www.youtube.com/watch?v=USsJS-BnGRY[/video]

The ST's first bark in 6 months
Comments greatly appreciated ;)
 
OP
OP
imp124

imp124

Buy & Sell Member
Club Member
im really pleased as everything in the engine bay is what i have done and it works, its a nice feeling
 
OP
OP
imp124

imp124

Buy & Sell Member
Club Member
Its running ok, i have only moved it backwards and forwards on the drive so far, probably really needs a run but im not insured and its got no tax but does have MOT lol, i might take it down my private road (seriously it is our land)
 

Baz

Ex. Club Member
Its running ok, i have only moved it backwards and forwards on the drive so far, probably really needs a run but im not insured and its got no tax but does have MOT lol, i might take it down my private road (seriously it is our land)
Cool hows the compression dude?
 
OP
OP
imp124

imp124

Buy & Sell Member
Club Member
it was borderline when i hadnt even run it gave it a quick run up and down today and it started ok, little lumpy but nowhere near as long as yesterday, then it runs smooth as butter
 

Snikty

Site Supporter
That's fantastic man! Glad to see your hard work and dedication to the car is finally giving you some good results.
 
OP
OP
imp124

imp124

Buy & Sell Member
Club Member
Cheers everyone,

Small update: Had her running again today took her for a very quick drive using no boost (s/c clutch didnt even come on) and drove good and didnt hesitate.
Also noticed when i came back that she was up to temperature at just over half way on the temp gauge and the fan was cutting in and out for 5-8 seconds, water looks clean, no bubbles in the expansion tank, cant see much in the way of leaks. Fingers crossed eh! :D

Steve
 

solarice

Ex. Club Member
sounds promising :D

BUT...no boost, thats not right at all...you should have it on just a little bit durong the test...thats why its there lol. Dont know how you could resist. :)
 

Baz

Ex. Club Member
Cheers everyone,

Small update: Had her running again today took her for a very quick drive using no boost (s/c clutch didnt even come on) and drove good and didnt hesitate.
Also noticed when i came back that she was up to temperature at just over half way on the temp gauge and the fan was cutting in and out for 5-8 seconds, water looks clean, no bubbles in the expansion tank, cant see much in the way of leaks. Fingers crossed eh! :D


Steve
Sounds good, temperatures normal over half way we've all covered this before.Fan activity (lol) sounds normal.

You should be able to boost it man. . .
 

Baz

Ex. Club Member
sounds promising :D

BUT...no boost, thats not right at all...you should have it on just a little bit durong the test...thats why its there lol. Dont know how you could resist. :)
If the clutch on the s/c did'nt engage you wouldnt get any boost at all and if he did'nt rev it pat 4500rpm he would'nt get any from the turbo either
 

solarice

Ex. Club Member
yeah, i know Baz :) (wasnt suggesting there was a fault) ;)

I couldnt have resisted having a mini boost session if i was test driving it (once i knew everything was good). But maybe im weak lol.
 
OP
OP
imp124

imp124

Buy & Sell Member
Club Member
No sorry if it was unclear, the s/c and everything works great i just dont want to blow it up again 1st day :D how many miles do you think to run it in?
 

Baz

Ex. Club Member
No sorry if it was unclear, the s/c and everything works great i just dont want to blow it up again 1st day :D how many miles do you think to run it in?
About 2-300 is what i would do with lots of gear changes to vary the revs.
 
OP
OP
imp124

imp124

Buy & Sell Member
Club Member
About 2-300 is what i would do with lots of gear changes to vary the revs.
Hard in an auto lol :D i get what you mean though, to get it to move it revs to about 2k and i havnt had it above 3 yet, just a little worried. im going to flush the water out as its got stuff floating on the top as i dont think i flushed it out from when it broke, we will see

Cheers

Steve
 

Baz

Ex. Club Member
Hard in an auto lol :D i get what you mean though, to get it to move it revs to about 2k and i havnt had it above 3 yet, just a little worried. im going to flush the water out as its got stuff floating on the top as i dont think i flushed it out from when it broke, we will see

Cheers

Steve
Keep forgeting man lol!

Good stuff ! all going well it seems
 
OP
OP
imp124

imp124

Buy & Sell Member
Club Member
A short victory...

Ok problems seem to have risen now, took it for a little run again, let it get to temperature and was running great, on the home stretch going approx 25mph i gave a teeny waft of boost 0.3 bar and suddenly it just stalled, now when i try to start it, it want to go you can hear it wanting to but it just cant seem to fire up! :(
 
OP
OP
imp124

imp124

Buy & Sell Member
Club Member
i cant see any pipes off at the moment i may have another look tomorrow, i just cant see whats up lol
 
OP
OP
imp124

imp124

Buy & Sell Member
Club Member
It lives again

Ok it is now fixed, John, Baz, correct as usual.

The problem was the intercooler pipe that runs through the passenger wing had come apart and were not together at all, this would explain not starting (air meter no air) and why it happened when it went into boost.

I put the pipe back on mega tight turned the key and started instantly!!!

Just need to make sure everything else is all tight / greased / clean / oiled / checked
 
OP
OP
imp124

imp124

Buy & Sell Member
Club Member
One thing i have noticed however is the water in the expansion tank runs low but the water in the rad looks ok, the expansion is only connected by the pressure release valve so i cant really see why it would be loosing water from here?

Steve
 

frank

Club Member
on our k11,s the radcap has a little return valve steve, so it sucks some water back from the overflow reservoir as the engine cools down (unless yours has the old expansion bottle type system where the pressurized cap is on the bottle and the rad has a sealed cap)
 

Baz

Ex. Club Member
One thing i have noticed however is the water in the expansion tank runs low but the water in the rad looks ok, the expansion is only connected by the pressure release valve so i cant really see why it would be loosing water from here?

Steve
That normal man, its losing it because your over filling it.Fill it about half way and leave it
 
OP
OP
imp124

imp124

Buy & Sell Member
Club Member
Ok i have done this and marked it up with a pen to where i filled it up

Frank i think this is the same type as the K11 as the expansion is not pressurised but the rad is :)
 
OP
OP
imp124

imp124

Buy & Sell Member
Club Member
Ok, now im taxed and insured we went on her maiden voyage which was very smooth and slow, told myself not to use the boost :D
 
OP
OP
imp124

imp124

Buy & Sell Member
Club Member
Trying to, its difficult as it wont really go over 40mph without using the s/c or turbo to give some boost, also i have been checking it everytime before i go out, oil, water, caps etc lol, paranoid now!
 
OP
OP
imp124

imp124

Buy & Sell Member
Club Member
im 19 and it was about 1400 there were not a lot of people willing to insure me
 

superls

K10 Tuner
yea i can imagine the phone calll.

yea its a micra, ok
its an import, erm ok
it has a supercharger, errrm ok
oh and it has a turbo, errrm just hold while i fetch the supervisor.

lol

just out of interest who are you with?
 
OP
OP
imp124

imp124

Buy & Sell Member
Club Member
i adrian flux i think it was a ring back service i remember that much will have to check

The guy i spoke to knew about the car but obviously couldnt find exact car so its a bit of a funny car quoted on the policy
 

Ed

Fusion Motorsport
MSC Founder
Official MSC Trader
Well done Steve. I was once with Adrian Flux and they did have the ST there when I phoned. Don't be afraid to use a little boost and throttle. Most big power cars I've worked on have been driven in fairly normally and not babied too much. Get those rings seated nicely :) Did you use new ones btw?
 

Baz

Ex. Club Member
Well done Steve. I was once with Adrian Flux and they did have the ST there when I phoned. Don't be afraid to use a little boost and throttle. Most big power cars I've worked on have been driven in fairly normally and not babied too much. Get those rings seated nicely :) Did you use new ones btw?
Yeah I told him to vary the load on the engine as best he can to bed the rings in. I think he used the original rings and honed the cylinders on the block i sent him
 
OP
OP
imp124

imp124

Buy & Sell Member
Club Member
Yes as Baz said i used the original rings, ring gap wasnt too bad and not much wear on the pistons, had the block very lightly honed just so you could see the cleaned up surfaces. I need to flush the radiator through again i think there are just little specs of dirt floating on the top. Hopefully going to get most of the engine tidied up this weekend too. Next major bit is an alarm as its getting noticed around here already :S

I will find out what the insurance docs say when i get them through, its going to be expensive running 2 cars :D
 

Baz

Ex. Club Member
Yes as Baz said i used the original rings, ring gap wasnt too bad and not much wear on the pistons, had the block very lightly honed just so you could see the cleaned up surfaces. I need to flush the radiator through again i think there are just little specs of dirt floating on the top. Hopefully going to get most of the engine tidied up this weekend too. Next major bit is an alarm as its getting noticed around here already :S

I will find out what the insurance docs say when i get them through, its going to be expensive running 2 cars :D


Clifford FTW
 
OP
OP
imp124

imp124

Buy & Sell Member
Club Member
im planning on getting a similar one to what was on my super s (that was a clifford) and i found it very useful
 
OP
OP
imp124

imp124

Buy & Sell Member
Club Member
One thing i have noticed is one reasonable sized oil leak coming from the flywheel side of the engine. Looks like this crank oil seal, although it was a new one, or the gasket around the seals housing? hopefully get this done when i take the gearbox off, would it fail an mot for this?
 
Top