Heater problem! Very bad!

My heater only works on position 4 (air comes through the vents nothing else) if I position towards my feet or both feet and head nothing happens..
this isn’t my heater resistor card as the speed 1-4 still works its the position of where the heat goes
Don’t know how to fix this it’s a struggle getting behind the heater dials
image.jpg
 
Is it weak on every setting? If so try pulling the pollen filter behind the glove box and see if it's any better. If so, new pollen filter. I was convinced the fans did nothing on my previous Micra, turned out the filter had never been replaced and had 16 years worth of leaves and dead flies in it.
 
OP
OP
Tan H
Is it weak on every setting? If so try pulling the pollen filter behind the glove box and see if it's any better. If so, new pollen filter. I was convinced the fans did nothing on my previous Micra, turned out the filter had never been replaced and had 16 years worth of leaves and dead flies in it.
I genuinely believe it doesn’t work at all! Feels very loose and just stays on that one setting. Difficult for this time of year too lol
 
Pull it out and check it. Best way to fix it. Kinda hard to say from a distance as we cant see the gears and stuff.
 
Take the center trim off, two screws above the stereo and two were the ash tray is, and take the stereo out and you can see if the knob, it's working the arm (it's to the right of the black heater box behind the stereo
 
OP
OP
Tan H
Take the center trim off, two screws above the stereo and two were the ash tray is, and take the stereo out and you can see if the knob, it's working the arm (it's to the right of the black heater box behind the stereo
Just did what you said and it looks like the arm has disconnected but is also stiff so how would I attach it again?
 
Top