Fast flashing/clicking OSR Indicator

Morning all,

Thought this an easy one but not fixed yet .... when indicating right, the indicator clicks fast and does not show at rear.

If I whack the light assembly, it returns to working ok. So I took the unit off, cleaned it up (actually in great shape), sprayed a bit of electrical cleaner in, fitted a new bulb and has worked the last 3 weeks. Yesterday it starts the fast clicking thing again .... whack the light assembly and it's ok for a while.

Any ideas folks? Thought this to be an easy one but I'm not shaking it off yet. Appreciate any ideas as always ... all the best
 

LiamC

I've ruined my car 🙁
Morning all,

Thought this an easy one but not fixed yet .... when indicating right, the indicator clicks fast and does not show at rear.

If I whack the light assembly, it returns to working ok. So I took the unit off, cleaned it up (actually in great shape), sprayed a bit of electrical cleaner in, fitted a new bulb and has worked the last 3 weeks. Yesterday it starts the fast clicking thing again .... whack the light assembly and it's ok for a while.

Any ideas folks? Thought this to be an easy one but I'm not shaking it off yet. Appreciate any ideas as always ... all the best
Usually happens when you've a bulb gone because there's less resistance and the system so it flashes faster

Sent from my FIG-LX1 using Micra Sports Club mobile app
 
I'd say if you whack it and the bulb returns to working then it's not a bulb issue, by whacking it your re-establishing contact with the bulb or somewhere along the circuit near the rear light, pull it apart look for dodgy connections or weak Springs holding the bulb contacts. You should be able to see if the filament (small wire) in the bulb is broken if not then the bulb isn't the problem.
 
OP
OP
3
yeah it doesn't look broken ... nor did the last one as it goes. Yes will give that a look at tomorrow (if not raining!!!) ... I read that the fast click does occur by design to indicate a failed bulb but as you say it looks ok and indeed works some of the time ..... trip down time again! Thanks for the steer
 
Top