Corsa piston build with throttle bodies

pork

Club Member
So engine is trashed.....

All good though as I’ve just picked up a cga3de block and crank from dave shaw (thanks mate)






Sent from my iPhone using Tapatalk
 
Last edited:

pork

Club Member
Well hopefully this time with a cga block it’ll go better

New pistons abs rings on order too


Sent from my iPhone using Tapatalk
 

pork

Club Member
Just got my cga3de block back, bored out and honed.....had to buy 4 new pistons too






Almost done polishing the head up, then il send that of to have the cr12 valves put in


Sent from my iPhone using Tapatalk
 

pork

Club Member
Gotta get a move on now to finish the micra.......me and the old man are gunna build one of these now



Had a look round the factory today, amazing cars!

Gunna stick the ls3 engine in it too


Sent from my iPhone using Tapatalk
 

pork

Club Member
Cheers dude.

Gotta see it through

Should be sending the head off for the valves to be fitted this week, got a tiny bit more polishing to do


Sent from my iPhone using Tapatalk
 

pork

Club Member
Head and valves sent off
Gave them the crank and rods too, all the bearings got trashed as well,so new bearings ordered and crank polishing


Sent from my iPhone using Tapatalk
 

pork

Club Member
Right......got all my bits back

Cga block re-bored/honed 3mm off the deck
New corsa pistons/rings
New main/big end bearings
Crank polished
Head diy port/polish, longer cr12 valves cut in, 2mm skim

I’ve got some cat cam springs coming too

Big dent in bank account





Sent from my iPhone using Tapatalk
 

pork

Club Member
Got my valve springs through, so can rebuild the head



Longer valves so I don’t have to double up the shims, plus they’re under Cr12 buckets, so no chance of spitting them out



New cg13 clutch, fitted to cg10 spline.......should stop the grinding noise whilst engaging gear




...........and because I’m a ####ing idiot, and didn’t check the cc in the head correctly before skimming it, I’ve had to get a de-comp plate from Ferriday Engineering to bring the c/r back down to 12:1



It was nearly 17:1

If it don’t work, then I’ve wasted all that time and effort polishing that head


Sent from my iPhone using Tapatalk
 

pork

Club Member
Well it’s dead again, after 15 miles

Comp test showed 5 bar on all cylinders

Taken head off



Have some pics........

Pistons as I found them






Block to gasket face



Head to Decomp plate face




Gasket to Decomp plate face



Gasket to Decomp plate face



Cleaned up the pistons and can’t see any cracks/ damage






Is there any way of telling if the rings are trashed without taking the block apart (can’t be ####ed......again)



I’ve sprayed some brake cleaner until it pooled on the pistons....it didn’t drain away, if this means anything


Opinions, suggestions........criticism, all accepted and appreciated


Sent from my iPhone using Tapatalk
 

pork

Club Member
Well it looks a lot cleaner from when I put it on, the wellseal is red colour.

And the plate in pic was as I found it.


You reckon new head and just a gasket theb


Sent from my iPhone using Tapatalk
 

pork

Club Member
i would try 2 old gaskets and see how it ran i guess mate, and if the compressions are back to normal then decide which way to go
2 gaskets ain’t enough to bring the cr down. That’s why I git the plate

You think if I rebuilt it with a new head gasket and resealed the plate then over over torque it, it’ll at least let me do a comp test again


Sent from my iPhone using Tapatalk
 

pork

Club Member
Had a closer look at the head and plate today

I can see sort of faint ‘blast’ marks coming from the combustion chamber parts

I’ve cleaned up and re-sealed and put it all back together,

Hope get to comp test tomorrow, got called out so couldn’t try today


Sent from my iPhone using Tapatalk
 

pork

Club Member
Had a quick go before work.

All cylinders went to 7bar

Put a smidge of oil down there, and went right up

Cylinder 1- 10bar

2-3-4 - 12bar

What does this mean then?

Cylinder 1 is trashed.

Or is it because I’ve only done 15miles on this fresh pistons/rings


Sent from my iPhone using Tapatalk
 
Had a quick go before work.

All cylinders went to 7bar

Put a smidge of oil down there, and went right up

Cylinder 1- 10bar

2-3-4 - 12bar

What does this mean then?

Cylinder 1 is trashed.

Or is it because I’ve only done 15miles on this fresh pistons/rings


Sent from my iPhone using Tapatalk
Doesn't necessarily mean the cylinders trashed. Could be a worn cam or a bad set of rings. Edit: or a leaking valve.
 

pork

Club Member
Well I’ve tried it again.........


Won’t start, compression gone down to 7ish bar


#### it !!!


Sent from my iPhone using Tapatalk
 

pork

Club Member
Had a spare hour today.

With old stuff I had:

Cylinder 1- 5 bar
Cylinder 2/3/4 - 7 bar

Tried a new head .......

Same results

Pulled out piston 1.......rings intact, bores look fine, hone marks still there,no signs of damage

Gunna pull engine apart, rebuild, start again


Sent from my iPhone using Tapatalk
 

pork

Club Member
After 15 miles

Hope not, what’s symptoms would I get with that?

All I’ve got so far is low compression and smoke from the breathers


Sent from my iPhone using Tapatalk
 

pork

Club Member
the overbore might have made them too thin maybe ? then they crack and leak compression into the crankcase
Thought beings I’ve used a cga3de this time, it’ll be ok, it’s only 0.5mm

Would of thought I’d if done the gasket or rings before the liners gave out

Il take a look once it’s in pieces again


Sent from my iPhone using Tapatalk
 
Top