Check engine light doesn't come on when I turn the key on. Engine won't start.

I have a 97 1.1 Micra and it wont start. It was working fine up until the other day.

When I turn the key to the "on position" the oil light, battery light and airbag light come on but the yellow engine light doesn't.

The other day i was trying to start it and while the engine was trying to start, the engine light started flickering on and off.

It then stayed on long enough for me to start the car. When the car was started I could hear a clicking sound from behind the dash that sounded like a relay with a bad connection. A kind of buzzing/clicking on and off sound and when it was making this sound, the engine light was flickering with the sound. The light flickering was happening exactly the same timing as the clicking sound.

The immobiliser light above the center dash fans goes out when I turn the key so I don't think it is an immobiliser fault.

As far as i can see there are two blue relays on the right hand side of the fuse box in the car by my right knee and two more in the engine relay box (rad fan, engine cont) I swapped some relays around but still no good. I cant get the ones beside the fuse box inside the car out because the dash is in the way but i can feel them clicking when i turn the key. What are them two relays for?

Any help would be greatly appreciated as the car is sorely missed. I can't wait to figure out what the problem is.


Buy & Sell Member
I had this problem when I removed the immobiliser/alarm box under the bonnet. Put it back and it worked again. Do you have an alarm fitted?


Club Member
I just did it by bridging the pins and nothing happened. No lights flashing or anything. The check engine light still doesn't come on.

Is there a relay or something I may have missed? One to trigger the ecu when you turn the key to the on position?
that plug is upside down sometimes aaron, the block is configured 2444 on that pic eh


Club Member
sound like a fuse problem eh, mine had a hairline crack in the fuse near the battery, a big single (green ?) one next to 2 slightly bigger ones
upright square ones eh

I did a continuity check on the square fuses and they are all fine.

I put the multimeter on the spades that the 85 and 86 pins of the engine cont relay plug into and i got 12v. However when I plug the relay in, it doesn't click. But the same relay will click if if manually put a 12v signal to them pins from the battery with two bits of wires.