C+C intelligent key half works?

Hi everyone, just today I've bought a not so used C+C 06 essenza - I spotted one for a decent price and thought keyless entry and heated seats sounded nice.

That was, until I drove it home and tried to lock the car...

I press the manual lock button, the key flashes, but the car doesn't lock? No response from the car. If I press the unlock, the locks don't make any attempt to unlock.

If I get in the car it just beeps at me a few times... But it starts fine. I can lock the doors with the internal lock button once, if I unlock them I have to close all the doors again or it beeps at me for as long as I hold the unlock button down.

What on earth is happening? I've tried the reset thing with the key but can't get the reset by turning it to "on" 6 times unfortunately. It's sat on the drive at the moment with the ability to have the engine switched on and it is happy to be driven away!!

(I am missing my 06 K12 micra SE so much now, it got rear ended so badly it was written off. This is very much rubbing salt in the wound...)
 
OP
OP
Rhi_D
Update

I've noticed that the key doesn't actually turn the ignition to the completely off "0" position, hence why it keeps beeping at me when I open the door. No garages open so will see on Monday if someone can get a look
 
Top