• Please only use these forums for blogs, they are not a discussion forum

Bens K10. The Second Micra

It's time for an update!!! Only a small one but i've actually done something to the K10 :)

Decided to have a go at sorting my rear bumper today. As my old was dented and dinged and not looking so good.
IMAG1510 (Large).jpg
Rolled the K10 out into the sunlight to get to the back. It's so close to starting but i'm waiting on some parts.

IMAG1512 (Large).jpg
No bumper shot, Yeah i did paint behind it just for the sake of it :)

IMAG1513 (Large).jpg
My new rear bumper. Well kind of, it's a bumper skin that is in much better condition than my old one attached to a not so good bumper bar.

IMAG1517 (Large).jpg
My old bumper bar. My mate helped me out in bending it back into shape. One of the previous owners had reversed into a pole or something and bent it in the middle. So we pulled it back into shape the best we could. I will get a whole bumper when i can track a preface rear bumper down.

IMAG1518 (Large).jpg
It's not the best but loads better then how it originally looked and it no longer pulls the plastic in with it :)

IMAG1520 (Large).jpg
A gap between the bumper and body, i think it's supposed to be like that but i don't know haha.

IMAG1525 (Large).jpg
Back on again and looking good. If only my phone camera was better at taking pictures.

Well that's about it for now. Still looking for a job so progress has slowed right down on the Micra :( I might wire up my fuel pump and regulator in the mean time and fill the gearbox back up. Ohh and i'm waiting on some parts to get back to me.
 

Attachments

Another small update. Decided to fill the K10 up with coolant, i used some cheap blue coolant from Euro car parts. It will be replaced with some genuine Nissan stuff after a couple hundred miles, I'm mainly using it just to clean the system up a bit and check for leaks.

IMAG1531 (Large).jpg
Brought my multi-meter with me so i can figure out some wiring for my fuel pump.
It's just as well i did'nt use genuine Nissan coolant as the pipes going to the heater matrix were slightly too big in diameter and started leaking. so i lost about 2-2.5L of coolant. Did'nt get a picture of that. Anyway. Some correct diameter pipe has been ordered and should show up soon :)

IMAG1533 (Large).jpg
I also managed to get hold of this today. Was not expecting to but a mate of mine had it made up and didn't want it as he was after an exhaust manifold flange and got this inlet manifold flange instead, so he sold it to me :) Just need to get some pipe welded onto it and that is my intake manifold sorted :)
Getting closer and closer to getting my CG13 started :D
 
Fair enough. I always thought there was a difference between stuff like that. I've never had to buy coolant before so i don't really know much about it. Guess i best do some more looking into it i think
 

MaxK11C

#Mallards
Moderator
Social Brand Manager
Fair enough. I always thought there was a difference between stuff like that. I've never had to buy coolant before so i don't really know much about it. Guess i best do some more looking into it i think
So did I, I was worried about putting sainsburys antifreeze in my daily.
Good to see progress Ben, JAE this year??
 
Oils and brake fluid etc etc i wouldn't cheap out on! But coolant doesn't matter as much

You can get waterless coolant which is good as it won't let anything G rust inside out, but apart from that coolant is coolant :)
 
Well it's not the big update i promised, but even that update is not so substantial.. Anyway. I was doing some research about upgrading the brakes on the K10. I found that Nissan Figaro's use vented discs and that the discs and callipers bolt right onto the K10 (as they should as a Figaro is a K10 in disguise lol)

So i found a set of callipers for £59 delivered. They are in really good nick and just need cleaning up and painting. However i won't fit them to the car just yet as i want to compare the difference between standard solid discs and the Figaro setup. I know i could have used K11 hubs and ran larger solid/vented discs but i think that the Figaro vented discs will be more then enough braking power for me :)

IMAG1556 (Large).jpg
 
Well it's not the big update i promised, but even that update is not so substantial.. Anyway. I was doing some research about upgrading the brakes on the K10. I found that Nissan Figaro's use vented discs and that the discs and callipers bolt right onto the K10 (as they should as a Figaro is a K10 in disguise lol)

So i found a set of callipers for £59 delivered. They are in really good nick and just need cleaning up and painting. However i won't fit them to the car just yet as i want to compare the difference between standard solid discs and the Figaro setup. I know i could have used K11 hubs and ran larger solid/vented discs but i think that the Figaro vented discs will be more then enough braking power for me :)

View attachment 47621
Nice find! Painting black?
 
Not an update but i just wanted to say it's been a whole year since i picked the K10 up!! I do remember i almost didn't buy it, I'm so glad i did :) Well here's to another year K10, can't wait to get you back on the road :)
IMAG0768.jpg
 
Update time woop!
Not been up recently but decided to do something to the K10. Thought it was time to sort the exhaust. Now i am going to get a custom system made up but for the time being i am going to use my 4-1 manifold with the standard exhaust system, just so i can get it driving.

IMAG1725 (Large).jpg
Put the bonnet back on just for the sake of it. It's not time yet to attach it properly

IMAG1727 (Large).jpg
Wings are really dirty might have to repaint them soon!

IMAG1728 (Large).jpg
Chopped up the old down pipe and had a mate weld on a reducer pipe so i could attach my manifold :)

IMAG1732 (Large).jpg
Yeah it's a pretty scabby pipe but it's not staying.

IMAG1733 (Large).jpg
My mate also welded up my manifold, it was blowing were the pipes collected but hopefully it's all sorted now :)

IMAG1734 (Large).jpg
He also welded up the hole for where the lambda sensor would go.

IMAG1735 (Large).jpg
More welded pics

IMAG1738 (Large).jpg
Manifold on! Should have used new exhaust gaskets but the old ones should be ok for now. Was a but of a pain to get the manifold on as the pipes are a little out of line but i got it in the end.

IMAG1741 (Large).jpg
Manifold now attached to the rest of the exhaust system :) Also as a bonus i'm pretty sure the K10 has a larger pipe diameter than K11's lol


I'll be back with another update soon as the exhaust is not attached yet and it needs sorting :)
 
Last edited:
Did some more work on the micra the other day. Mainly just to get the exhaust mouted up again.

IMG_1360 (Large).JPG
Got the back jacked up so i can get underneath. Yeah the crap pile on the side is not all todo with me, it's gonna be cleaned up soon when the Micra can move under it's own power!

IMG_1361 (Large).JPG
Cable tying your backbox up? Why not i do it and it works pretty well haha! It's not staying like this honest, once i get the money a proper custom system is being made up so i won't need any cable ties :L (hopefully!)

IMG_1362 (Large).JPG
Exhaust is back in place! Just need to tighten up the clamps and ajust my cable ties and it'll be all good :)

IMG_1364 (Large).JPG
The standard system lines up quite nicely with my CG manifold, the manifold is actually one of frank's creations.

IMG_1365 (Large).JPG
Almost there! literally just waiting for my dizzy to come back from Andy and i can try starting it up! (update on inlet manifold soon)

IMG_1366 (Large).JPG
Hehe looking good! The bay is a bit messy but i just want to get it running before i start worrying about dirty engine bays :L

IMG_1368 (Large).JPG

Another zorst pic for good measure :L

Well thats that for now (if you can call it an update) i guess i'm just messing around with small bits while waiting for the important part to show up (dizzy) i do have a friend making up my inlet manifold so i'll put that on here when it's done :)
 

Attachments

Good news! I have just found out that my distributor will be done by next week :D Which means i can actually get the K10 started up... I am so hyped right now!

In other news i filled the CG up with oil as i hadn't got round to it yet :L, found out my oil pressure light works and finally got my exhaust lined up and clamped up lol

IMG_1372 (Large).JPG
Finally got some oil in engine. Got it free as part of a euro car parts deal haha

IMG_1374 (Large).JPG
Exhaust is clamped up and bolted up. Hopefully it's not going to leak.

IMG_1375 (Large).JPG
The alignment was a little out on where the reducer pipe had been welded on hence why this is not sitting right, but it's close enough and shouldn't cause too many problems.

IMG_1377 (Large).JPG
I probably shouldn't include this picture, but the rear section of the exhaust is now in place. The bit of duct tape on top is holding a block of wood so it doesn't hit on the body. I do love cable ties.... haha

IMG_1380 (Large).JPG
All in place now, that cable tie supports the pipe and stops it from moving too much. Been like that since before JAE, everyone said it would of melted off but the old ones lasted over 1000 miles haha

IMG_1382 (Large).JPG
Backbox still sticks out too much, but it'll do for now :L

Well that's the exhaust part done, not been too exciting but trying to think of all the small things that need doing. Dizzy should be turning up soon and my intake manifold will be done this week! So hopefully i should have a starting up video maybe even before the end of may! :D
 

Attachments

Small progress update, my mates welder has gone kaput so he can't finish off my intake manifold at the moment and my distributor somewhere between being done and being posted. The way things are going it really does look like i'm not making it to Japshow (9th July) in the K10. I am really disappointed with that as now i'm going to have to take my ratty K11 daily in it's place.

So thats it for now. I don't really have anything to update on, just thought i'd say why i've been so quiet on the MSC :(
 
Small progress update, my mates welder has gone kaput so he can't finish off my intake manifold at the moment and my distributor somewhere between being done and being posted. The way things are going it really does look like i'm not making it to Japshow (9th July) in the K10. I am really disappointed with that as now i'm going to have to take my ratty K11 daily in it's place.

So thats it for now. I don't really have anything to update on, just thought i'd say why i've been so quiet on the MSC :(
Sorry to hear mate :( Looks like there's only gonna be 2 10's on the stand now then :(
 
Well i know the updates have been a bit few and far between but i'm back with a new idea on getting the K10 up and running again, since getting my MA dizzy to work with the CG is proving much more difficult than first thought.

I'm probably crazy but i'm planning on using a K11 loom so i can run fuel injection. I don't really know all that much about engine looms but i'm going to try my best as i've got a month before JAE!!

So i picked this up today.
IMAG1924 (Large).jpg

It's a full wiring loom for a K11. I'm not really sure how much of it i actually need but since it's a nats loom i need the ignition barrel and key so i need most of the dash loom. So hopefully tomorrow i'm going to start sticking this loom into the car and hope for the best! The plan is just to have this loom to run the engine and the K10 loom to run everything else

Fingers crossed i suppose!

I got the loom of Connor, i can't remember his forum name but he's got a fab K10 with an MA12 and bike carbs! Looks awesome, but it currently needs a clutch as it ate the old one up haha
IMAG1926 (Large).jpg
 
Made a start today on project fuel injection. started taking the bits i needed of my spare CG13 and putting them onto the K10. Luckily the intake manifold fits nicely in the engine bay as i was worried about it fowling on the firewall.

IMG_0003 (Large).JPG
Nice big ol mess of wires. Some how got to fit this into the 10 and make it work. Passenger footwell is going to get messy!

IMG_0004 (Large).JPG
Looking the same as always, i really do miss my little 80's eco hatch :(

IMG_0005 (Large).JPG
All the intake side of things i need on the spare engine, when i bought it i never expected to actually use any of it but it's a nice bonus that the previous owner left it on for me :)

IMG_0006 (Large).JPG
This thing is hard enough to get off even when the engine is out of the car, i wouldn't fancy taking it off in a K11 engine bay.

IMG_0007 (Large).JPG


IMG_0009 (Large).JPG
Easy access on them bolts, fab bit of design that is Nissan lol

IMG_0010 (Large).JPG
First problem i've found is my firewall hole is too small. Guess a drill saw is required :/

IMG_0011 (Large).JPG
Anyone have any idea's on what this little takeoff pipe on the TB is? Can't remember where it went

IMG_0012 (Large).JPG

Same for this one on the intake manifold. Big one is for the brake servo but no idea what the little one is :S

Well that's it for now, gonna clean the intake manifold and throttle body up a bit before i stick it back onto the engine. Then the fun can begin on working out where everything needs to go on the K11 loom.
 
Oh yeah, I remember how annoying it was to reach some of those bolts back behind all the hoses and everything. Shame I can't really help you with K10 attendance on JAE. Even though I will hopefully have mine running by then, it's a tad too far and fuel costs alone would be enough to buy another K10 or two. However, I can help you with the mystery takeoffs:



I'm not 100% sure on the orange one as it doesn't seem to line up with the diagram, but hopefully this should be at least of some help. Also, keep in mind the photos are of a LHD car, so the brake servo is on the other side, etc. Your mileage may vary :)

Best of luck getting her to run on time!
 

frank

Club Member
the one on the t/b is very close to the throttleplate ben, so no actual mani vacuum but a high venturi flow at low throttle (to vent the white plastic canister purge valve on the end of the head)
 
Right time for some updates. This lot of pictures of from about a week ago, i just forgot to upload them last week so i'm doing it now haha

Well as said in my last post i tracked down a rare mid spoiler, i have been after one of these since i got the K10. As soon as i saw this one pop up close to me for £40, i bit the blokes arm off for it!!
Decided to test fit it as i wanted to see how good it would look and i'm not disappointed! I've even got the top spoiler to go with it :)
IMG_0013 (Large).JPG
That scoring on my rear window is bad, thanks to the previous owners for pretty much not having a wiper blade on the back.....

IMG_0014 (Large).JPG
Yes looks so good! Also coincidentally it's the same colour as my car originally was

IMG_0015 (Large).JPG


IMG_0016 (Large).JPG
Got the inlet manifold on, was a bit of a struggle with the bolts at the bottom but i got there in the end.

IMG_0018 (Large).JPG
Sorted this pipe with a screw, it's a vacuum takeoff for the carbon canister (thanks for the help btw guys!) so i won't need it anymore

IMG_0019 (Large).JPG
Found a convenient piece of pipe to connect back up to my brake servo, i'm guessing the CG will make a better vacuum than the MA motor so hopefully my brakes will work better ;)

IMG_0022 (Large).JPG
Thanks to @Connorstew for tagging some of these plugs helped me figure out where everything is going

IMG_0042 (Large).JPG

Well that's the intake manifold and distributor wired up and the few other bits. So that is the ECU wiring loom done, just need a 40mm drill saw for my firewall and then i can start feeding everything through. (this is getting confusing i must say haha)

IMG_0023 (Large).JPG
Also any idea's on what this plug is for? it's on the same bit of loom as that black relay and i can't find anything (yet) for it to plug into!

Well that's the first half of this update. Today's antic's will be uploaded very soon :)
 

Attachments

Last edited:
So today i carried on with sorting on my many parts of the K11 loom, managed to get pretty much everything in place so just waiting for my drill saw bit to enlarge my hole in the firewall so i can start getting everything connected up. Hopefully when it's all connected up i'll be able to turn the key and it burst into life, but somehow i think it's not quite going to work out that easy lol

IMG_0041 (Large).JPG
All the parts of the loom that control the engine have been connected up, won't be able to use my lambda sensor yet as i had the hole in my manifold welded up thinking i'd never need it haha

IMG_0043 (Large).JPG
Hmm yes lots of loom parts, and starting to look pretty messy. No hopes of having a tidy engine bay with all this wiring in it.

IMG_0044 (Large).JPG
My electrical tape also decided to do this no idea why. I was going to buy black electrical tape but couldn't find any in Wilko. It actually works out better for me as i can see what i've taped up so if i need to go back to something i can tell if i've messed with it or not haha

IMG_0046 (Large).JPG
Some good advice from a friend of mine was to tape up connectors i know i'm not using so i can easily tell that i don't need to use them. It also keeps them from shorting out on anything (slim chance i know but still)

IMG_0047 (Large).JPG
This is the wiring on the K11 for the starter motor, i'm guessing the big cable is the positive yes? Can i get away with not using this? I'm using the K10 loom for the starter so i've not got anywhere to but the big cable, would it effect the loom if i were to leave it disconnected? I am going to use the negative from this as i seem to have alot of places to put positive connections but not alot of negative ones lol.

IMG_0049 (Large).JPG
Time i got rid of my coil, unfortunately i won't be needing it anymore :'(

IMG_0050 (Large).JPG
The interior/dash loom from the K11. I spent a bit of time on this taping up some of the loose and unneeded wires/plugs.

IMG_0051 (Large).JPG
This was one part of the loom that was on the drivers side that went back into the engine bay to control the right hand side lights. I could not get to the drivers side wing to get that part of the loom so i had to chop it off. I am certain i won't need any of it though.

IMG_0052 (Large).JPG
This is the other part of the dash/interior loom that i didn't need. It's all the wiring for the rear lights, washer, rear wiper ect... All taped up to stop shorting. They will be all be taped up into one bundle once i know for sure that i don't need anything from this.

IMG_0054 (Large).JPG
Interior loom loosely put into place, luckly i think i'll be able to get away with hiding most of it under the carpet. It's stay loose until i know i won't need to mess with it again. Also i'm not sure where the fuse box is going yet lol

IMG_0055 (Large).JPG
More of the dash loom laid out loosely, this is only getting a little bit confusing, but it's ok. I think i know what most of this is for haha.

IMG_0056 (Large).JPG
This is the setup for the carbs i was going to be using with the CG, it's a little rough and ready but i've only got it set up like this as a temp measure. I will be replacing the pump for a standard K11 fuel pump later, but this should do for now just to get it started up.

IMG_0058 (Large).JPG
Slightly bodgy wiring on the alternator. Got the K10 and the K11 loom on it. "Should be fine" lol

IMG_0059 (Large).JPG
Yep this still confuses the heck out of me and it looks messy :/

IMG_0060 (Large).JPG

Well that's another few updates done with. As much as i don't want to say this, the K10 won't be coming to JAE with me. Mainly because i won't be able to afford the insurance and i've just remembered the MOT ran out in June hahaha. Hopefully i'll get this CG running in no time though. It's been pretty much 9 months since i put the K10 in this garage and i bloody well miss driving it!
I wish i had just stuck with an MA swap and found an MA12 and put bike carbs on that! Would have worked out so much better lol
 

Attachments

Update time!
Got a drill saw ordered and got a bigger hole drilled in the firewall (60mm to be exact) so i could get the last of my wiring connected up, just need a few earths sorting and my ignition barrel and then i can try and see if it'll start!!
Also managed to find one of @frank 's lightened 160mm flywheels so i will fit that at some point when my cheapy ebay clutch decides to brake lol

IMG_0061 (Large).JPG
Ohh yeah forgot to mention i imported some Datsun March lights in from Japan!! One is used and the other is 1982 NOS!! (New Old Stock)

IMG_0063 (Large).JPG
Apart from them being the other way around, the datsun light also sits more flush with the bodywork, i know it's not much difference but i like them! Will be quite a challenge getting the lights out though as my Micra lights almost seem to be bonded in!

IMG_0064 (Large).JPG
My new 60mm hole, sprayed with some primer to stop it from rusting.

IMG_0065 (Large).JPG
Woop! ECU plug fits and now can have it in the cabin :)

IMG_0066 (Large).JPG
These two connections are for the starter motor on the K11. I know the bigger connector is a possitive but is the smaller one a negative or a positive?

IMG_0067 (Large).JPG
Kind of disabled the Waxstat, would have taken it all off but i did'nt have the right screwdrivers with me!

IMG_0068 (Large).JPG
Current situation with the wiring! Clocks are just for testing, and i should be able to hide most of this up under the dash.

IMG_0069 (Large).JPG
Found a nice place for the ECU to live under the dash, will have to make up some kind of bracket or get busy with the cable ties haha

IMG_0070 (Large).JPG
My awesome frank modified flywheel! Will get it fitted at some point but glad i got it! Paired with my Tomei cams, my K10 is gonna fly! :)

IMG_0071 (Large).JPG
Bit rusty but i will clean it up before it goes into the car.

IMG_0072 (Large).JPG
it's pretty thin, no idea on the weight of it though.

IMG_0074 (Large).JPG
Also with the flywheel came a custom 170mm clutch and clutch pressure plate also modded by frank, the 170mm is the top right, standard 160 is to it's left and the 180 is at the bottom.

IMG_0075 (Large).JPG
Close up of the 170mm. It's a 160 centre with 180 friction material with the edges chamfered to allow the 160 pressure plate to fit over it. No idea if i'll use it or not but it's pretty cool.

That's it for now, just waiting on my ignition barrel and we'll be able to see if it start! :)
 

pork

Club Member
I used/using the same clutch setup on my s/c mini, had it in the home brew superturbo I did too, worked a treat!
And had it all bolted to the k10 4 speed, which survived somehow lol


Sent from my iPhone using Tapatalk
 
Top