Audew Air Horn - fuse keeps blowing!

My horn failed and so instead of buying an equivalent replacement, I decided to go one louder and buy this:

s-l1600.jpg

s-l1600 (1).jpg


HOWEVER, the one I bought didn't come with the relay or yellow block connector with the 4 wires coming out.

Regardless of this, I still connected it up and inevitably the 10amp horn fuse keeps blowing. You can see from the image above that on the relay, it says 80amp, and so my 10amp fuse stands no chance.

So I have contacted the company so they can send the relay and yellow block connector to me, BUT I am a complete novice at electronics (I barely managed to wire some prefacelift taillights into a facelift).

How do I wire a relay, I can't make sense of the stuff on the web.
Thanks for any advice.
 
Last edited:
Have just put a return in on eBay for the air horn and ordered an OEM replacement, really can't be asked wasting time with petty things like a horn tbh.

THREAD CAN BE REMOVED.
 
Last edited:
I bought one of these once, never managed to fit it

The issue is that while they draw a continuous current while operating, to start a compressor there is a massive surge

The fuses have to be rated for the surge current, the wire you can get away with slightly thinner but if you use it a bunch of times in a row they may melt.

As for wiring a relay, it has to do with how many pins. For a better understanding search on youtube for "how to test a #-pin relay" and it'll explain what each pin does. They're usually labled with the same numbers, like 78+, 78- or 40... those aren't amps they're just the names of the pins. There's a magnet inside that closes and opens a circuit.
 

SuperUno

Buy & Sell Member
K11 horns are already wired through a relay, on my rally car I just took the live feed from the OEM horn and attached it to the positive on the compressor, added an earth and it works a treat.
 
K11 horns are already wired through a relay, on my rally car I just took the live feed from the OEM horn and attached it to the positive on the compressor, added an earth and it works a treat.
Ah I thought they would already have a relay but dunno why mine kept blowing.

I did exactly as you say - took the live feed from OEM and connected to compressor and earthed the negative to the chassis but it didnt work.

Got a full refund and bought a Bosch Fanfare Horn, which looks OEM but sounds like the truck horn lol. And it works without popping fuses.
 
Top