Recent content by IrishK11

  1. IrishK11

    Charging problems

    Well I managed to get a replacement fuse and shes charging just fine at the moment. If it dies again I'll have to have the alternator looked at I reckon. Thanks for all the help guys! Sent from my Nexus 5 using Tapatalk
  2. IrishK11

    Charging problems

    Success of sorts. Got the broken fuse ends out. But have no ways of getting a new one today so looks like she's parked up for a while.... No corrosion either which makes me think this wasn't the cause of my problem... Sent from my Nexus 5 using Tapatalk
  3. IrishK11

    Charging problems

    See if I hadn't had the alternator completely rebuilt 6 months ago it would have been the first thing I did but I have a feeling it's something else just can't figure what. Now I've made a balls of my fusebox am gonna have to sort that before I can go any further. Plan was to put the Micra up...
  4. IrishK11

    Charging problems

    Was really hoping it wouldn't come to that as its well past my abilities...may need to call an autoelectricion.... Sent from my Nexus 5 using Tapatalk
  5. IrishK11

    Charging problems

    Good to know! A friend is actually on his way to bring me to get a fuse but my issue still remains, can't budge the remainder of the fuse from the contacts. Any suggestions? Pulling and twisting with a pliers is only tearing the metal... Sent from my Nexus 5 using Tapatalk
  6. IrishK11

    Charging problems

    Will try this once I have sorted my battery fuse (see above pic) it broke when extracting and the two contact prongs are welded to the fuse board it would seem. Can't get them out for the life of me! [emoji20] Sent from my Nexus 5 using Tapatalk
  7. IrishK11

    Charging problems

    I figured they should have come out I must have broken them off when yanking the fuse, they're properly welded in there tho so I expect this is where my problem lies. Sent from my Nexus 5 using Tapatalk
  8. IrishK11

    Charging problems

    No dash lights at all, and car doesn't start just turns over. Sent from my Nexus 5 using Tapatalk
  9. IrishK11

    Charging problems

    Sent from my Nexus 5 using Tapatalk
  10. IrishK11

    Charging problems

    Got the fuse out but not in one piece so unsure if I broke it in the process or was already broken? Had it been broken previously the battery light would have come on though yes? Also should the two prongs seen in the pic have come out with the fuse? Sent from my Nexus 5 using Tapatalk
  11. IrishK11

    Charging problems

    Should the 80a fuse just pull out? It won't budge?? Sent from my Nexus 5 using Tapatalk
  12. IrishK11

    Charging problems

    OK just took some readings. Engine off 12.5v Engine running no load 14.3v Engine running with all electrical items on 14.1v. So it would seem its charging OK now. But I've done nothing to remedy the problem which means is eventually going to stop charging... Sent from my Nexus 5 using Tapatalk
  13. IrishK11

    Charging problems

    Don't see it stuck through here mate! Sent from my Nexus 5 using Tapatalk
  14. IrishK11

    Charging problems

    Cheers mate now to call on my school knowledge of wiring diagrams ha! Gonna be a fun day... Sent from my Nexus 5 using Tapatalk
  15. IrishK11

    Charging problems

    I will double check the fuses but all appeared OK at first glance. Shall double check the alternator mounting as well. Thanks :) Sent from my Nexus 5 using Tapatalk
Top