Rear Wiper problem

Discussion in 'K11 Tuning Mechanical Servicing and Modifications' started by pstez84, Feb 7, 2010.

  1. pstez84

    pstez84 New Member

    Hi there, hope someone can help.
    My Rear wiper seems to have stopped function in my Micra, It became it be tempremental for a few months (wouldn't automatically park, just stayed in the position it was when I switch off the control) but not it has just stopped working. I've checked the fuse - all fine, I also convinced myelf it was the motor so i ordered a new one but it still doesn't work. After scouring the internet I discoverd that it could be something to do with either the wiper relay or the wiper stalk. As far as I understand, the wiper relay is next to the motor so surely my replacement motor would include a new wiper relay? Does this mean it is the stalk that's faulty? or worse...the wiring? If it's the stalk, how do you get them out? Any help or advice would be much appreciated. Thanks a lot
  2. getawaycar

    getawaycar New Member

    Are you getting battery voltage and an earth at the motor?
    If you are you have bought a dodgy motor!
    If you are not getting power or earth to the motor you have to trace it back. There isn't any easy way to diagnose the fault unless you want to just chuck parts at it.

    From what you describe, when the motor starts to misbehave it is usually a sign the motor is on its way out and unless you checked the replacement it could be you have fitted a duff one.

    It could also be something to do with the connector at the wiper unit (were the terminals clean and rust free? Did the plug release easily?) or the wiring that goes from the bodyshell to the tailgate. Easily checked by pulling the rubber tubing back at the top right corner of the tailgate apeture.

    Wiper switches usually burn out and melt inside and you can usually feel the difference when you switch them on. When they do this it is usually because there is another fault in the circuit. (Wrong fuse used, poor earth connection).
  3. rydan79

    rydan79 Buy & Sell Member

    As above,check the wiring that goes from the bodyshell to the tailgate. Same thing happened on my wifes micra,the wiper+ number plate lights stopped working so pulled back the rubber tubing to find 3 wires broke and 1 hanging on by a thead!.
    Common problem i believe.
  4. pstez84

    pstez84 New Member

    Thanks a lot people! I haven't had time to play around yet, still dark in the evenings so hard to do after work, but I'll get to it soon.
    Just another question, I plan on using a voltmeter to check there's enough power getting there - if any. Do you know how many Volts I'm expecting to read?

    Thanks again, I appreciate your advice!
  5. halow

    halow New Member

    ref rear wiper motor 3 wires midddle live and outer 2 earths they switch , to live on operation , sometimes wiper may move , bcm ( body control module ) thinks it frozen rear wiper and turns off re prog bcm or replace bcm

Share This Page